Jump to content


Photo
- - - - -

Help with Virtual Kid Tamagotchi


  • This topic is locked This topic is locked

envy_131

  • envy-131 user photo
  • Group: Members
  • Posts: 2 posts
  • Joined: 21-May 12

Posted 25 May 2012 - 10:57 PM ( #1 )

Hi everyone. I just receive my Virtual Kid today in the mail that I purchase from ebay. Unfortunately the item is not working properly even when I changed the batteries. It restart itself. The pixel and the sound is not working properly as well. I was told it is new but the screen and the back of the item has a lot of scratches!

Should I bring it to the shop for a repair or ask for my money back?

By the way, here is how the item looks like:-

http://www.ebay.com....48#ht_500wt_922

Replies

2

Views

491

Started

25 May 2012

Last Post

08 Jun 2012

</html>

  • html user photo
  • Group: Members
  • Posts: 75 posts
  • Joined: 04-April 12

Posted 08 June 2012 - 08:26 AM ( #2 )

Well,It says in the description that the item has been in their store for 10 years,electronics,break eventually.

Mothra

  • mothra user photo
  • Group: Senior TamaTalk Guides
  • Posts: 3,356 posts
  • Joined: 19-June 04

Posted 08 June 2012 - 10:51 AM ( #3 )

You have to keep in mind that when you buy these things, they will be at least 10 years old now. Electronics go weird after a while. First try to clean it out. There might be some stuff behind the reset button. Also be sure that the contacts are nice and clean.
Also, there is a good chance of a lot of small scratches caused by the packages. Weird but true.

Don't bother the seller please.