Jump to content


Photo
- - - - -

1999 furby


  • This topic is locked This topic is locked

kimbercarl

  • kimbercarl user photo
  • Group: Members
  • Posts: 2 posts
  • Joined: 14-September 13

Posted 14 September 2013 - 06:49 PM ( #1 )

I found my 4 Furbies 2 if them are not working one is a baby what do i need to do the other one batteries were in there with corrosion how do i fix it i missed them and so happy to find them so my kids can now play with them

Replies

2

Views

411

Started

14 Sep 2013

Last Post

15 Sep 2013

SailorRosette

  • sailorrosette user photo
  • Group: TamaTalk Guides
  • Posts: 5,443 posts
  • Joined: 15-September 08

Posted 14 September 2013 - 07:16 PM ( #2 )

You need to take out the batteries if you plan on not playing with them. Otherwise, they do tend to corrod the batteries faster. (Then other things in my opinion) They warn about that in all the instructions...

Anyway. You need to open up the bottoms and scrape off all the white/acid off the furby. It should help and hopefully you don't need to go futher inside. If it doesn't wake up, you'll likely need to scrape/clean off the insides under the fur, by the moving gears.

I would also look up "my furby keeps falling asleep" (after being turned on) These instructions should tell you how to remove the fur. If you put the batteries in and find your furby doing the wake up to only fall asleep thing... Follow those directions. Its getting common to find furby that don't "wake up" so those instructions are very helpful if you need them.

kimbercarl

  • kimbercarl user photo
  • Group: Members
  • Posts: 2 posts
  • Joined: 14-September 13

Posted 15 September 2013 - 06:59 AM ( #3 )

Thank you i thought they were with my ex and my mom found them so i didn't know batteries were in them i will look more into them