Jump to content


Photo
- - - - -

American Tamagotchi Ocean screen fades after button press?


  • This topic is locked This topic is locked

Ashashichi

  • ashashichi user photo
  • Group: Members
  • Posts: 142 posts
  • Joined: 24-July 12

Posted 08 March 2014 - 02:07 PM ( #1 )

I'm annoyed with a seller on eBay cause the listing said it was a mint condition Ocean but when I recieved it the back cover and screw holes had scratches and really bad nicks.

 

Then when I put in NEW BATTERIES the screen has a fading problem.

 

Where it'll darken up to normal when I press a button/do stuff but not a few seconds later it fades to being barely visible :<

 

Anyone know how to fix the screen? (trying to see if I can get some sort of money back for this clearly heavily used Ocean -_-)



Replies

8

Views

269

Started

08 Mar 2014

Last Post

15 Mar 2014

Midorime

  • midorime user photo
  • Group: Members
  • Posts: 1,312 posts
  • Joined: 14-November 12

Posted 08 March 2014 - 10:49 PM ( #2 )

Open a case on Ebay since the item was not as described.



Ashashichi

  • ashashichi user photo
  • Group: Members
  • Posts: 142 posts
  • Joined: 24-July 12

Posted 09 March 2014 - 07:04 AM ( #3 )

I will if the seller won't give me at least 70 of the 170 I paid for this :/ She was sort of playing dumb about how the scratches got there.

 

I don't think customs would go out of their way to open it and put scratches all over the back.



Midorime

  • midorime user photo
  • Group: Members
  • Posts: 1,312 posts
  • Joined: 14-November 12

Posted 09 March 2014 - 09:59 AM ( #4 )

Not sure, but I know some customs/shipping services don't allow batteries to be in items when shipping. Did it look like the package was opened? Have you tried calling customs to ask them?



Ashashichi

  • ashashichi user photo
  • Group: Members
  • Posts: 142 posts
  • Joined: 24-July 12

Posted 09 March 2014 - 11:20 AM ( #5 )

Nah the package looked fine, no tampering at all and I've never heard of customs removing batteries before. At least not in the states...



Ashashichi

  • ashashichi user photo
  • Group: Members
  • Posts: 142 posts
  • Joined: 24-July 12

Posted 10 March 2014 - 02:41 PM ( #6 )

its been a couple days since I asked for a refund with no response, getting a little antsy and even more annoyed...



Midorime

  • midorime user photo
  • Group: Members
  • Posts: 1,312 posts
  • Joined: 14-November 12

Posted 11 March 2014 - 09:32 AM ( #7 )

But did you actually file a report with Ebay themselves via the Resolution Center?



Ashashichi

  • ashashichi user photo
  • Group: Members
  • Posts: 142 posts
  • Joined: 24-July 12

Posted 12 March 2014 - 06:53 AM ( #8 )

But did you actually file a report with Ebay themselves via the Resolution Center?

yeah, she gave me a partial refund of 50 instead of 70.

 

Better than nothing, I suppose.



Jokus

  • jokus user photo
  • Group: Members
  • Posts: 555 posts
  • Joined: 06-September 12

Posted 15 March 2014 - 01:52 PM ( #9 )

I'm sorry for you, I hope you can get it to work.
For me, that kind of screen problems have always been because of battery issues. Maybe the batteries are old, or of a cheap brand?
If it isn't the batteries, it might be dust or damage by the screen connectors iside the tama, then it's up to you if you want to open it up and look for things potetially causing the glitching.
Good luck!