• 0
Sign in to follow this  
chris133d{tama lover}

help

Question

5 answers to this question

Recommended Posts

  • 0
Fine deal... Did it say the batteryand the x on the screen!? Also if it did it may just be a glitch did she ty restarting it? Was the battery from the shop or did it come with the tama? Edited by tamagirl228

Share this post


Link to post
Share on other sites
  • 0
The batteries don't usually die that fast, but maybe they were just bad batteries to begin with.
New ones should last longer.

Share this post


Link to post
Share on other sites
  • 0
those might be poorly made batterys..........download your tama and you should get a little more time. mine did the same , after a month 1/2 , my sisters v3 was giving mine a present , and wen the present should have showed up , the batterys were dead! she gave mine dead batterys

Share this post


Link to post
Share on other sites
  • 0
It's alright, sometimes the battery which comes with the Tamagotchi is not very good. It's probably because it sits in the Tamagotchi for a very long time before it is used and might be "out-of-date". Also, I find that V2 and V3 use batteries faster than V1. Plus, your sister and you both have Tamagotchis Do you connect a lot? If so, this could be using up the batteries. Usually batteries fail during connection because it is the time when the most power is required. My dad said that using the sound would probably wear out the batteries as well.
StarTama :furawatchi:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this