Jump to content


Photo
- - - - -

Changed the batteries...but they still don't work


  • This topic is locked This topic is locked

tita

  • tita user photo
  • Group: Members
  • Posts: 1 posts
  • Joined: 12-October 06

Posted 12 October 2006 - 05:43 PM ( #1 )

Hi, I hope someone can help. I have 4 Tamagotchis. I just changed the batteries on all 4 and they don't work. I tried the reset buttons, but nothing happens. The screens are dead. What should I do????

Thanks!!!!

Replies

3

Views

279

Started

12 Oct 2006

Last Post

13 Oct 2006

hey_everyone

  • hey-everyone user photo
  • Group: Members
  • Posts: 14 posts
  • Joined: 06-April 06

Posted 12 October 2006 - 06:09 PM ( #2 )

Did you put them in the right way?

Tama-Love

  • tama-love user photo
  • Group: Retired TamaTalk Guides
  • Posts: 2,560 posts
  • Joined: 11-June 06

Posted 12 October 2006 - 06:11 PM ( #3 )

First, are they the ones that work on Tamagotchis? They are a special kind. :D You should try checking the number on the ones you put in, and post them! Then we can start from there, good luck! :D

~Tama-Love~

dancinkayley

  • dancinkayley user photo
  • Group: Members
  • Posts: 2,671 posts
  • Joined: 26-December 05

Posted 13 October 2006 - 12:26 AM ( #4 )

Check these things:

-The battery is CR-2032 3V
-The plus side is up
-Your Tamagotchi isn't broken. If you haven't tampered with them send the Tamagotchi to BanDai!

One time I fixed my friend's Tamagotchi by simply putting in the correct battery.