Rainey0713

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by Rainey0713

  1. I can't recall a specific incident, but for sure I have dropped it a few times / exposed it lightly into rain, it was my childhood Tamagotchi.. I took it everywhere with me and it definitely had a few accidents. But what I remember is that it stoped working unexpectedly.. I mean, it wasn't a "rough" day with big accidents. I may try a different brand of battery one of those days, although I believe that's not the problem.. But I'll have to try everything first before I jump into conclusions 😅😂 I will try it and let you know, thank you for your time!
  2. Hello again! So, I tried bending upwards the battery-contacts, but unfortunately it made no difference 😥 Thank you for your time and interest though!
  3. I haven't tried this because I believe that it's not a battery problem.. There is no harm into trying though, so I will do it and let you know shortly after.. thank you! 😊
  4. So, for years now, my Tamagotchi Connection V4 doesn't really ever turn on.. Once I put in the battery, the egg appears on the screen and it works normally for about 10-15 seconds or so.. it then shows one or two horizontal lines on the screen and it shuts off. If I press the reset button, it will show the egg all over again, but it's a matter of time for the same thing to happen.. I believe it's not a battery problem, because it turns on with the reset button without moving or changing the battery (also, the same battery works on my V4.5 just fine). Lastly, I recently opened it up and cleaned everything inside, even the buttons, but it still won't work. Please, anyone who may know something or having experience on that matter, let me know on what to do! I feel very nostalgic lately, and I really want to bring my "dead" Tamagotchis back to life, starting from this one. Thank you all in advance!