Sign in to follow this  
Priestess of Syrinx

Love-Chu won't turn on

Recommended Posts

I recently bought a pair of Love-Chu,version 1's, off ebay. However, when I put batteries in them, they won't start. One of them came on for a brief second but that's it. These are brand new batteries.

 

Does anyone have any experience with these pets? Is there any trick to getting these guys to boot?

Share this post


Link to post
Share on other sites

If they were described as used, I would recommend looking into the inner workings of the pet to make sure that there's nothing wrong (such as sound wires, disconnected wiring for the Tamagotchi to start up), but be careful with doing so. Making a mistake during that procedure may damage it even more if it's already damaged on the inside.

Edited by ~SkrillexGotchi~

Share this post


Link to post
Share on other sites

Visually everything looks good (though I accidentally pulled apart the LCD on the one I took apart, will probably have to re-align that if I get it working again...), unfortunately I don't have access to a multimetre or anything like that.

 

The batteries I use are 'Replaces AG13/LR44', not actual LR44s. I've never had a problem with them on other pets, is there precedence for those being an issue?

Share this post


Link to post
Share on other sites

That's the problem, you need actual LR44 button batteries. I would recommend Rayovac, Energizer, or Duracell.

 

If those don't work either, then the battery contacts for the pet might be dirty or corroded.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this