GrumpyPoney

My retro vpet batteries leaked, it don't turn on !

Recommended Posts

Hi,

I don't know if I'm on the good topic, but here my problem. I bought a retro vpet called space creature brand as new. But as I opened it, the batteries leaked and the pet don't turn on with new ones. I noticed some brown rusty stuff on the connection of the pet. Someone can help please ?

 

spacer.png

 

vl5e.jpg

a8sm.jpg

 

The toy can be saved  ? I hope cause I really wanted it 😢

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello, that's terrible 😢 There is a chance to save it though! You need to clean the battery contacts with cotton dipped with contact cleaner / something high alcohol based that doesn't leave residue, and hope for the best. . .

  • Like 3

Share this post


Link to post
Share on other sites

What @321Boom said + check the batteries are making contact with all of the metal prongs (bend them a little to ensure good contact).

  • Like 3

Share this post


Link to post
Share on other sites

All I can say is try your best to clean it or scratch of the rust if this doesn’t help there is not much I can do sorry ☹️ 

 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.