Nostalgia_Addict

(HELP!!) Pixel Chix Broke

Recommended Posts

So I just found my old Pixel Chix Babysitter House, I tried to put in the batteries and it did turn on, but the lights are dim, no characters can be found, the red light is on and the door bell keeps ringing everytime I even so as touch the crank. Is there anyway to fix this?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

According to the instruction manual (found it over here!), it says that turning the crank to the living room starts the game, though I'm not sure why the mom isn't on the screen comparing to what it says:

Quote

When the unit is turned on for the first time, the mom will be on the screen, and the doorbell will ring. Turn to the living room if that room is not already showing. The mom will greet the Pixel Chix Gal and they will talk. The mom leaves and the Pixel Chix Gal has a job to do!

It's possible you may not have gone there yet? I think the dim lights are normal for this part, I'm not sure (I haven't played the Babysitter House in so long). Hopefully this helps out! This was one of my favourite Pixel Chix models growing up, though I don't have one anymore. :( If it still doesn't work, I recommend pressing the reset button on the back, or replacing the batteries. Good luck! :D

Edited by Tamacass
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah idk what's going on, no characters are on the screen but I can hear them talking plain as day. The lights flicker sometimes too. I tried the reset button but it still was acting this way. I'm not sure what to do cause I really wanna salvage this one haha. My mom something might be loose, but I don't have the slightest idea about disassembling and reassembling it, and I don't wanna make it worse. I can't afford a new one either so I'm kinda stuck. 😓

Edited by Nostalgia_Addict
  • Sad 1

Share this post


Link to post
Share on other sites
14 hours ago, Nostalgia_Addict said:

I tried the reset button but it still was acting this way.

My 1 and 2 storey houses used to do this all the time! What I used to do is take the batteries out and put them back in. Works for me, but if it doesn’t for you; try a different brand.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.