Sign in to follow this  
tchelle

replaced batteries...still nothing

Recommended Posts

I got my kids a tamagotchi for Christmas...it's the kind where they can interact with their friends. Well, the batteries went dead in both games and I finally remembered to get some. I got the correct kind and all, and then when I replaced them, still nothing happened. It's like this on BOTH tamagotchi's. When I first put the battery in, it worked for like 3 or 4 seconds and then blank again...nothing. What is going on? Any help would be greatly appreciated.

 

:D tchelle

Share this post


Link to post
Share on other sites

Perhaps they are broken. But it would be pretty weird that it's both of them together. Are you COMPLETELY ABSOLUTELY POSITIVELY SURE that you put in a CR-2032 3V lithium battery? One of my friends put in a CR-2025 3V battery, and wondered why it wasn't working.

 

If all else fails, send it in to BanDai.

Share this post


Link to post
Share on other sites

r u sure u don't have the crappie tamas and not the WORKING tamas that actually WORK RIGHT? B) the USA tamas are the best tamas and the chinnese tamas r so CRAPPIE that they like didn't even change them from the V1's, they just added an antennae to V1's. :huh:

Share this post


Link to post
Share on other sites

AH HAH!!! DancinKayley, you're SO smart!!! I did get the 2025 battery, instead of the 2032! I will go and get the correct ones and once again be SUPERMOM! Jade...I am 31, I know, I know, much too old to be on a tamagotchi fan site, but needed help on what to do about the battery, my oldest child really does enjoy this toy, and I guess I wasn't smart enough to figure out that I had the wrong battery. Thanks to all from the bottom of my frustrated heart!!

 

Tchelle

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this