Sign in to follow this  
TamaAngelV3

Batteries, already?!

Recommended Posts

I have 10 V3's, all batteries died because I didn't use them alot, well the last V3 I started up was yesterday, and the batteries already died. However, I've had the tama fo a few months, I just didn't start it up till yesterday, as in the tab was in for maybe 6 months, and I took it out yesterday, just to clear things up. Anyone know why this happened? Help is much appreiciated (somehow I know I spelt that wrong ^_^ )

Edited by TamaAngelV3

Share this post


Link to post
Share on other sites

As batteries sit around, even if they are not being used in anything, their power diminishes.

 

It could have been a bad battery when you bought the tama new, and it sitting around just made it worse.

Share this post


Link to post
Share on other sites
I have 10 V3's, all batteries died because I didn't use them alot, well the last V3 I started up was yesterday, and the batteries already died. However, I've had the tama fo a few months, I just didn't start it up till yesterday, as in the tab was in for maybe 6 months, and I took it out yesterday, just to clear things up. Anyone know why this happened? Help is much appreiciated (somehow I know I spelt that wrong :unsure: )

Maybe it was the brand of the batteries that you had. Although they could get weak just sitting there. Try buying a different brand of batteries.

Share this post


Link to post
Share on other sites

Thanks for the help, but my friend just called and I asked her and she told me to try reseting and then downloading it and that worked, even though I did buy new batteries...

Share this post


Link to post
Share on other sites

Mhmm, true about downloading but the battery is still low, i kept doing that to mine and after about 3 weeks it went dead, and i had to put new batteries in.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this