Tamagotchi 2017 Usatama LCD Screen Damage

Help Support TamaTalk:

KidRetro64

Well-known member
Joined
Mar 25, 2018
Messages
373
Reaction score
230
Location
Not Telling
Hello, folks!  :)

In spite of easter, I decided a few days ago to run my Usatama in celebration. I went ahead today and removed the old batteries, and popped in the new. I’d done this numerous times before, so I didn’t think anything of it.

As soon as I put the new ones in, the screen was black. All the pixels were filled in (which gave me hope, as that meant the batteries were making contact) apart from a few ‘scrambled’ ones in the top left corner. I took them out immediately, as I didn’t want to damage in device further and permanently damage the screen. When my Dad got back (the one who helps me with all of my Tama-issues) :p  he tried himself, with more dead pixels in different patterns. He tried resetting, nothing. There were just random pixels on the screen (image attached for reference to what they roughly looked like at the time) with no response from the reset or ABC buttons.

We tried again, this time the clock displaying and the device beeping. As I finally thought it worked, the ‘12’ which was supposed to be on the left side of the screen was.. missing? I tried to click ABC over and over, but it appeared to be frozen. Took them out again, and put them back in. Not expecting much. There was more garbage on the screen and then.. clicking? It sounded like something was going horribly wrong in the battery compartment. It went on clicking until I demanded my Dad to take out the batteries before it completely short-circuited itself.

Since then, it’s been displaying dead pixels on and off, but most of the time nothing at all. The buttons are unresponsive, along with the speaker and reset. 

I also want to mention a few things before I get suggested them, as I have already tried most of the Google results provided!

  • The brand of batteries is Duracel, which is the same brand I used for the batteries previously, along with all of my other virtual pets. I’ve never had any issues with their batteries until now.



  • While all of this was happening, the battery cover was off, meaning nothing was causing pressure on the batteries or LCD.



  • I’ve ran this Tamagotchi without any hassle before, this is the first time it has happened.



  • The batteries and compartment are completely clean and intact.



I’d appreciate it greatly if anyone had any advice or ideas on how to resolve this issue, it would mean a lot to me and my Tama!  :lol:

Here is what we are getting on the screen right now (With batteries in). When we take them out, simply nothing is displayed. It was showing completely black before, but it looks similar to this;

You can clearly see faint and darker lines scattered across the screen, but before it was similar to garbage sprites and pixels. Hopefully this gives people a better idea of what i’m dealing with!

7FCFB36D-91D6-4251-962D-5849DBDDCECB.jpeg

 
Last edited by a moderator:

Penguin-keeper

TamaTalk Guides
Staff member
Joined
Dec 23, 2017
Messages
1,796
Reaction score
2,813
The brand of batteries is Duracel, which is the same brand I used for the batteries previously, along with all of my other virtual pets. I’ve never had any issues with their batteries until now.
Just for extra clarity, here: Are the batteries in-date?

Aside from that, how has the device been stored?

 

KidRetro64

Well-known member
Joined
Mar 25, 2018
Messages
373
Reaction score
230
Location
Not Telling
Just for extra clarity, here: Are the batteries in-date?
I bought them 2 days ago from Sainsbury’s, so I would hope so!  :p

Aside from that, how has the device been stored?
It’s been in a drawer for 6 months without use with all my other Bandai Tamagotchis. I’ve played with them on and off with no trouble.

 

Penguin-keeper

TamaTalk Guides
Staff member
Joined
Dec 23, 2017
Messages
1,796
Reaction score
2,813
I bought them 2 days ago from Sainsbury’s, so I would hope so!  :p
Hahaha! I would hope so too! :lol:

It’s been in a drawer for 6 months without use with all my other Bandai Tamagotchis. I’ve played with them on and off with no trouble.
I must admit, given this I'm completely puzzled by what's happening here - you've covered all of the bases, already. I really hope that someone is able to shed light on this one so that we can all improve our knowledge!

 
Top